Browse our Products

If so you can download any of the below versions for testing. The product will function as normal except for an evaluation limitation. At the time of purchase we provide a license file via email that will allow the product to work in its full capacity. If you would also like an evaluation license to test without any restrictions for 30 days, please follow the directions provided here.

Télécharger la bibliothèque de programmation Python Aspose.Finance pour les formats XBRL, iXBRL, OFX

Aspose.Finance pour Python via .NET est une API autonome sur site composée de classes Python qui vous permettent de traiter et de manipuler des formats liés à la finance, tels que XBRL, iXBRL et OFX. Veuillez utiliser ce qui suit pépincommande:

>

Product Page | Docs | Examples | Blog | Search | Free Support | Temporary License

Fonctionnalités de l’API Python sur site pour le traitement des fichiers financiers

  • Créer une instance XBRL à partir de zéro.
  • Créez un fichier iXBRL à partir de zéro.
  • Créer une requête OFX à partir de zéro.
  • Créez une réponse OFX à partir de zéro.
  • Lire les formats XBRL et iXBRL.
  • Lire ou écrire la requête OFX.
  • Lire ou écrire la réponse OFX.
  • Prend en charge la validation XBRL et iXBRL.
  • Importer et exporter des fichiers au format XBRL & iXBRL.
  • Gérer l’élément abstrait dans la taxonomie XBRL.
  • Convertir l’instance XBRL en iXBRL (inline XBRL).
  • Convertissez iXBRL (inline XBRL) en XBRL.
  • Convertir l’instance XBRL en XLSX.
  • Convertissez iXBRL (inline XBRL) en XLSX.
  • Convertir la requête OFX Version 1 en requête OFX.
  • Convertir la réponse OFX en réponse OFX Version 1.
  • Valider l’instance XBRL.
  • Validez iXBRL (inline XBRL).

Lire les formats financiers

XBRL, iXBRL, OFX

### Systèmes d’exploitation pris en charge

Microsoft Windows® : Bureau et serveur Windows (x64, x86)
Linux : Ubuntu, OpenSUSE, CentOS et autres
Autre : Tout système d’exploitation (SE) pouvant installer Mono (prise en charge de .NET 4.0 Framework) ou utiliser .NET core.

Plate-forme Linux cible

Bibliothèques d’exécution : GCC-6 (ou version ultérieure)
.NET Core : Dépendances de .NET Core Runtime. L’installation de .NET Core Runtime lui-même n’est PAS requise.
Pour Python 3.5-3.7 : La version “pymalloc” de Python est nécessaire. L’option de construction Python --with-pymalloc est activée par défaut. Typiquement, la construction pymalloc de Python est marquée avec le suffixe m dans le nom de fichier.
Bibliothèque Python : bibliothèque Python partagée libpython



Direct Download


 Français